[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
- To: common-lisp at SU-AI
- Subject: GET/PUT names
- From: Earl A. Killian <EAK at MIT-MC>
- Date: Mon, 01 Feb 1982 23:32:00 -0000
I don't like the name GET for property lists. GET is a verb, and
therefore doesn't sound very applicative to me. I prefer Lisp
function names to refer to what they do, not how they do it.
Thus I'd like something like PROPERTY-VALUE, PROPERTY, or just
PROP (depending on how important a short name is) instead of GET.
PUTPROP would be SET-PROPERTY-VALUE, SET-PROPERTY, or SET-PROP,
though I'd personally use SETF instead:
(SETF (PROP S 'X) Y)