[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[no subject]

I don't like the name MAKE because it suggests a constructor, not a
mutator. eg, I would expect MAKE-PAIR to mean CONS, not DISPLACE.

For the sake of those at CMU trying to get the first system out the
door, I would suggest that we not spend a lot of time on non-critical
naming issues until we get some of the more major issues worked out.
The change you suggest is an upward compatible one which can safely
be discussed later. The existence of the name SETF will not significantly
impair existing programming since the operator's functionality is at
least stable. At an appropriate later time, it would probably be worth
reviving this issue as in the long run, I too feel that SETF is not